This version of Microsoft SQL Server Management Studio can only be used to connect to SQL Server 2000 and SQL Server 2005 servers

Error:

This version of Microsoft SQL Server Management Studio can only be used to connect to SQL Server 2000 and SQL Server 2005 servers. (ConnectionDlg)
 
 
Solution:
You can get the above error if you are trying to connect to SQL Server 2008 from a SQL Server 2005 client without the latest service pack. I had the same problem and all that I had to do was to install Service Pack 3 for SQL Server 2005 and it solved the problem. You can download the Service Pack 3 for SQL Server 2005 from here.
 
 
How to Check and Identify your SQL Server Version Number?
To determine which version of Microsoft SQL Server 2005 is running, connect to SQL Server 2005 by using SQL Server Management Studio, and then run the following Transact-SQL statement.
 
SELECT  SERVERPROPERTY('productversion'), SERVERPROPERTY ('productlevel'), SERVERPROPERTY ('edition')
 
Or
 
In SQL Server Management Studio,
Click on the Help Menu  à Then Select About , that should bring the following window and you should be able to see your Version number and know if you have the latest Service Pack.
As shown in the following diagram my version number is 9.00.2047.00 which means I have the Service Pack 1 installed but I am missing Service Pack 2 and 3. The table after the diagram below helps you to relate the Service Pack with the version number.
 
 
The following table lists the Sqlservr.exe version number.
Collapse this tableExpand this table

Release
Sqlservr.exe
RTM
2005.90.1399
SQL Server 2005 Service Pack 1
2005.90.2047
SQL Server 2005 Service Pack 2
2005.90.3042
SQL Server 2005 Service Pack 3
2005.90.4035
 
References:
Tags: